Plenty of script-driven applications, particularly paid cms, encode their files in order to ensure that they won't be reverse engineered or tampered with. Many of them use an application named ionCube PHP Encoder to do this, so if you get a paid script and you would like to set it up in a hosting account, a tool called ionCube Loader needs to be present on your server. Without this, you cannot install the script or if you somehow find a way to do this, it won't operate appropriately due to the fact that most of the script code will be encrypted to a point where it cannot be interpreted. In this light, you should make sure that ionCube Loader is present if you get a new hosting account and you wish to take advantage of some paid web application. If you acquire a shared website hosting account and the instrument is not present, it can't be added because your entire server PHP environment shall have to be compiled again.

IonCube in Shared Hosting

IonCube Loader is provided with all of the shared hosting packages that we supply, so if you require it to install and run some script application that needs it, you can enable it with a single click in the Advanced section of your Hepsia Control Panel. Because you'll be able to change the PHP release that is active for your account in the same section, you will have to activate the instrument for each new version which you set. If you are more experienced, you'll be able to take advantage of a php.ini file in a domain or subdomain folder and set both the PHP version as well as the status of ionCube Loader for that particular site only, without affecting the entire account. Thus you can manage both new and older script applications for multiple sites within the same account - something that you will not be able to do with various other hosting suppliers out there.

IonCube in Semi-dedicated Servers

In case you get a semi-dedicated server package from us, you will be able to take advantage of any kind of script-driven application which requires ionCube Loader for the reason that the tool comes with all servers that are a part of our revolutionary cloud web hosting platform. Furthermore, we support different releases of PHP, therefore if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for that particular version with just a click in your Hepsia Control Panel. Our platform will remember your choice, and if you switch back to the previous version of PHP, the software tool will already be active. For more tech-savvy users, we also provide the option to choose the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the whole hosting account. This can be done by placing a php.ini file in a domain folder with a few lines of program code.